Uživatelské nástroje

Nástroje pro tento web


cs:openscad

Rozdíly

Zde můžete vidět rozdíly mezi vybranou verzí a aktuální verzí dané stránky.

Odkaz na výstup diff

Obě strany předchozí revize Předchozí verze
Následující verze
Předchozí verze
cs:openscad [2019/04/21 23:52]
kaklik [Styl psaní kódu (coding style)]
cs:openscad [2019/07/21 12:04] (aktuální)
kaklik
Řádek 4: Řádek 4:
  
  
-=== Styl psaní kódu (coding style) ===+==== Styl psaní kódu (coding style) ​====
  
 Je praktické dodržovat některá základní pravidla při vytváření modelů v openscadu. Je praktické dodržovat některá základní pravidla při vytváření modelů v openscadu.
Řádek 25: Řádek 25:
  
  
-== Názvy souborů ==+==== Názvy souborů ​====
  
 Názvy jednotlivých souborů modelů jsou číselné ve formátu //​(Název_)XXX_XXXX.scad//​ kde první trojčíslí určuje zamýšlený materiál ze kterého se má model realizovat: ​ Názvy jednotlivých souborů modelů jsou číselné ve formátu //​(Název_)XXX_XXXX.scad//​ kde první trojčíslí určuje zamýšlený materiál ze kterého se má model realizovat: ​
Řádek 38: Řádek 38:
  
  
 +==== Knihovny ====
  
 +Knihovny by v projektech měly být ve složce // src/lib/ //, s tím že složka lib může mít další podsložky. Například standardní knihovny společné pro více projektů ve formě submodulu. ​
 +Submodul s knihovnami vytvoříme příkazem ​
 +
 +  git submodule add git@github.com:​ThunderFly-aerospace/​Openscad_stdlib.git lib/stdlib
 +
 +
 +
 +==== Alternativní editory ====
 +
 +Integrovaný editor v OpenSCADu není moc pohodlný pro užívání. Je proto vhodnější zdrojové kódy modelů editovat v jiném editoru. OpenSCAD to podporuje tím, že při novém uložení souboru znovu zobrazí náhled. Některé editory podporují pluginy, které znají jazyk OpenSCADdu.
 +
 +
 +=== Použití editoru Atom ===
 +
 +Editor atom je pro tento účel vhodným editorem. Instalace je docela jednoduchá a rychlá. Editor pak nabízí mnoho pokročilých funkcí.
 +
 +Instalace lze provést v nastavení, do kterého se dostaneme přes ```Edit -> Preferences``` (klávesová zklatka ctlr+, (čárka)). V levém sloupci nastavení je potřeba zvolit `install` a vyhledat ```language-openscad```. Následně je potřeba nainstalovat stejnojmenný plugin.
 +
 +Pak stačí otevřít soubor a editor by měl sám poznat, že se jedná o OpenSCAD soubor. Bude se to projevovat tak, že syntaxe bude správně obarvená a bude to znát určité openscad funkce.
  
 === Použití editoru SublimeText === === Použití editoru SublimeText ===
  
-Editor integrovaný přímo do OpenSCADu není moc pohodlný pro užívání. Je proto vhodnější zdrojové kódy modelů editovat v editoru ​[[https://​www.sublimetext.com/​|SublimeText 3]].  K tomu je ale vhodné si do editoru nainstalovat plugin, který zná jazyk OpenSCADdu+Další vhodný editor je [[https://​www.sublimetext.com/​|SublimeText 3]].
  
-Instalaci lze provést přes systém balíčků, který můžeme aktivovat volbou //Tools -> Install Package Control..//​. ​+Instalaci ​pluginu ​lze provést přes systém balíčků, který můžeme aktivovat volbou //Tools -> Install Package Control..//​. ​
  
 {{:​cs:​sw:​sublimetext3_package_control_install.png?​400|}} {{:​cs:​sw:​sublimetext3_package_control_install.png?​400|}}
cs/openscad.1555883534.txt.gz · Poslední úprava: 2019/04/21 23:52 autor: kaklik